<!DOCTYPE html> <html lang="en-US"> <head> <script>var pb_global={pageName:"article-template",pageId:"rHJ9vP1Xz0ktKr",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"keyc"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>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</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="7Lyz0BKVwAtvLVjWOrAmJslZ1vzx2MmaR8Dd1amlDxY"/> <title>Minnesota lawmakers meet to pass aid for businesses, workers</title> <meta name="keywords" content="KEYC News Now, KEYC News, KEYC, Coronavirus, Coronavirus Relief, Coronavirus Minnesota, COVID-19, COVID-19 Minnesota, COVID-19 Relief, Corona, Special Session, Minnesota Businesses, Releif Package, MN Businesses"> <meta name="news_keywords" content="KEYC News Now, KEYC News, KEYC, Coronavirus, Coronavirus Relief, Coronavirus Minnesota, COVID-19, COVID-19 Minnesota, COVID-19 Relief, Corona, Special Session, Minnesota Businesses, Releif Package, MN Businesses"/> <meta name="date" content="2020-12-14T21:43:31.694Z"/> <meta itemprop="description" name="description" content="Minnesota lawmakers were convening Monday to try to pass a $216 million relief package aimed at businesses and workers who took the biggest hit from a four-week “pause” ordered by Gov. Tim Walz."/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="https://www.keyc.com/2020/12/14/minnesota-lawmakers-meet-pass-aid-businesses-workers/"> <meta name="twitter:title" content="Minnesota lawmakers meet to pass aid for businesses, workers"/> <meta name="twitter:image" content="https://www.keyc.com/resizer/qboC3tUkNx_o32TspOM8j_dB1HM=/1200x0/cloudfront-us-east-1.images.arcpublishing.com/raycom/JWCPJVZLWVAFNJLRKOVHZRRF4Y.jpeg"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="Minnesota lawmakers were convening Monday to try to pass a $216 million relief package aimed at businesses and workers who took the biggest hit from a four-week “pause” ordered by Gov. Tim Walz."/> <meta name="twitter:site" content="@keycnews12"/> <meta name="twitter:creator" content="@keycnews12"> <meta property="og:url" content="https://www.keyc.com/2020/12/14/minnesota-lawmakers-meet-pass-aid-businesses-workers/"/> <meta property="og:title" content="Minnesota lawmakers meet to pass aid for businesses, workers"/> <meta itemprop="image" property="og:image" content="https://www.keyc.com/resizer/qboC3tUkNx_o32TspOM8j_dB1HM=/1200x0/cloudfront-us-east-1.images.arcpublishing.com/raycom/JWCPJVZLWVAFNJLRKOVHZRRF4Y.jpeg"/> <meta property="og:description" content="Minnesota lawmakers were convening Monday to try to pass a $216 million relief package aimed at businesses and workers who took the biggest hit from a four-week “pause” ordered by Gov. Tim Walz."/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="https://www.keyc.com"/> <meta property="og:type" content="article"/> <meta property="fb:app_id" content="103460183161125"/> <meta property="fb:pages" content="103460183161125"/> <meta property="fb:admins" content="644426401"/> <meta name="burst" content="keyc"/> <meta property="article:publisher" content="https://www.facebook.com/keycnews12/"> <meta property="article:tag" content="Minnesota, MN, State, Politics, Special Session, Lawmakers, Congress, House, Senate, COVID-19, Coronavirus, Corona, Relief, Relief Package, Bill, Business, Businesses, Workers"> <link rel="amphtml" href="/2020/12/14/minnesota-lawmakers-meet-pass-aid-businesses-workers/?outputType=amp"> <meta name="author" content="STEVE KARNOWSKI"> <script data-schema="NewsArticle" type="application/ld+json">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</script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "KEYC",
        "url": "https://www.keyc.com",
        "logo": "https://www.keyc.com/pb/resources/images/rm_icons/keyc-icon.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://www.facebook.com/keycnews12/" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/199071bbaf3b531cbc00/rm/rm-framework199071bbaf3b531cbc00.css?v=101" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/keyc-logo.svg?v=101)}.logo.logo-footer{background-image:url(/pb/resources/images/footer_icons/keyc-logo.svg?v=101)}</style> <link href="/pb/resources/dist/199071bbaf3b531cbc00/rm/rm-framework199071bbaf3b531cbc00.css?v=101" rel="stylesheet"/> <link href="/pb/resources/dist/199071bbaf3b531cbc00/rm/rm-features199071bbaf3b531cbc00.css?v=101" rel="stylesheet"/> <link href="/pb/resources/dist/199071bbaf3b531cbc00/rm/rm-services199071bbaf3b531cbc00.css?v=101" rel="stylesheet"/> <script>!function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://reconditerespect.com/v2kgz_gZwMtdQ-MXx1ZTGRJIrgvEBn96JTtPVrclNhoOgSQnse5hAa8Gt",o.parentNode.insertBefore(t,o)}(document,"script"),function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}}(window,"admiral");
!function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)}(window,"googletag","function");
!function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if(function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}}(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=
function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://reconditerespect.com/v2ufmF9jGLeMMbTgj9HfFELGE6T_RuT6TgqwYJpgr0fOi8ijcm61JirTq9gyrrwIFs6FpryH8aA",t.parentNode.insertBefore(o,t)}(document,window,"__uspapi","__uspapiLocator","script");</script> <script src="/pb/gr/c/default/rHJ9vP1Xz0ktKr/arcAdsJS/cdbd7d78da.js?v=101"></script> <script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> <script>!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement("iframe");t.display="none",t.onload=function(){var n=t.contentWindow.document,c=n.createElement("script");c.src="//cd.connatix.com/connatix.playspace.js",c.setAttribute("async","1"),c.setAttribute("type","text/javascript"),n.body.appendChild(c)},n.head.appendChild(t)}}(document);</script> 
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-95d6bda9-2845-4d89-bce9-d0d5fbf5fa71","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false"}]);</script>
  <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="2VR6G-E2BN8-BNYUE-CD6K5-5HRUN",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"2VR6G-E2BN8-BNYUE-CD6K5-5HRUN",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubaxglq3ux6x5ila-f-caba6f6a4-clientnsv4-s.akamaihd.net",i={"ak.v":"29","ak.cp":"848692","ak.ai":parseInt("542132",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"bc81463","ak.r":30159,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":48686,"ak.gh":"23.50.225.182","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1607985686","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==vFXGF/aMk4sl3NYoxdPrsiJGpP7XaQIFNHffb/nN8pcVfeca8BSgRmWWwMbjcQeNd+KI8oc8pChbljKmPMSEqi9JmTSfdd+FDng9olb3V0OO4hwrDQ6ahze4CiCNW5WueDErk8kjV0DHLgo1zSlIOaS7AtDVqBQNcoJDiQX/cl92HbUyglOylsN0645vmSU64P3kweCtCXnN4A0s6Aivtr3FN92D/TpxvNSY1yIC6bwQl6Y190Ge2BfnztQECf4Ml5amFfieznOYj/4Sf4uApr+T9rjdhodGeZKJFVJQifsxtq1xdSnQKTXIakRj1XRE3oNHj6VC7o39NIQY9KkX87cOjFcjCpX0Vp+Zjiuf8QD/M1406rqldLLcalDm3mNCfPyrEq2nE41DJqkGDR4wMuA9NkOOarxbXG2zcfEmLF8=","ak.pv":"10","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> 
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-95d6bda9-2845-4d89-bce9-d0d5fbf5fa71","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false"}]);</script>
  <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="2VR6G-E2BN8-BNYUE-CD6K5-5HRUN",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"2VR6G-E2BN8-BNYUE-CD6K5-5HRUN",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubaxglq3ux6x5ila-f-caba6f6a4-clientnsv4-s.akamaihd.net",i={"ak.v":"29","ak.cp":"848692","ak.ai":parseInt("542132",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"bc81463","ak.r":30159,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":48686,"ak.gh":"23.50.225.182","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1607985686","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==vFXGF/aMk4sl3NYoxdPrsiJGpP7XaQIFNHffb/nN8pcVfeca8BSgRmWWwMbjcQeNd+KI8oc8pChbljKmPMSEqi9JmTSfdd+FDng9olb3V0OO4hwrDQ6ahze4CiCNW5WueDErk8kjV0DHLgo1zSlIOaS7AtDVqBQNcoJDiQX/cl92HbUyglOylsN0645vmSU64P3kweCtCXnN4A0s6Aivtr3FN92D/TpxvNSY1yIC6bwQl6Y190Ge2BfnztQECf4Ml5amFfieznOYj/4Sf4uApr+T9rjdhodGeZKJFVJQifsxtq1xdSnQKTXIakRj1XRE3oNHj6VC7o39NIQY9KkX87cOjFcjCpX0Vp+Zjiuf8QD/M1406rqldLLcalDm3mNCfPyrEq2nE41DJqkGDR4wMuA9NkOOarxbXG2zcfEmLF8=","ak.pv":"10","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative zindex-higher col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="faYVSr1Xz0ktKr"> <div id="sales-nav" class="background-grey-minimal visible-lg"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.keyc.com/community/user-content/" class="color-grey-dark">Your Photos</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.keyc.com/weather/closings/" class="color-grey-dark">Closings & Delays</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.keyc.com/community/calendar/?/" class="color-grey-dark">Community Calendar</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.keyc.com/programming/schedule/" class="color-grey-dark">What's On CBS, FOX, NBC, & CW</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.keyc.com/contests/" class="color-grey-dark">Contests</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.keyc.com/about-us/" class="color-grey-dark">About Us</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.keyc.com/2019/11/15/programming-start-soon-nbc-cw/" class="color-grey-dark">About KEYC NBC</a></li> </ul> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" id="f0aKfloXz0ktKr"> <style>.pb-f-article-body .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 200px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}.pb-f-article-body .card .img-container.width-full,.pb-f-article-header .card .img-container.width-full{background-color:#f9f9f9}.pb-f-article-header .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 150px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}</style> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky zindex-higher col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="f0ExsO8Xz0ktKr"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.keyc.com"> <div class="logo logo-slim"></div> </a> </div> <div class="app-bar-top-container flex-3 flex-container-row relative spaced spaced-sm spaced-left spaced-right hidden-sm"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="https://www.graytvlocal.com/market/mankato-mn" class="">Business Guide</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="https://www.keyc.com/live/" class="">Watch Live</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/community" class="">Community</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/health/coronavirus" class="">Coronavirus</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="https://grow.withgray.tv/keyc/" class="">Advertise</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/toys-for-tots/" class="">Toys for Tots</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div class="app-bar-tray" data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full zindex-high tray-open visible' : 'tray left-0 hidden width-full zindex-high hidden'" class="tray left-0 hidden width-full zindex-high"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <div class="flex-grid"> <div class="tray-section tray-section-1 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/homepage" class="color-white">Home</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="https://www.keyc.com/live/" class="color-white">Watch Live</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/community/user-content" class="color-white">Your Photos</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/2019/05/24/send-us-news-tip/" class="color-white">Send Us a News Tip</a> </div> </div> </div> </div> <div class="tray-section tray-section-2 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/news" class="color-white">News</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/news/morning" class="color-white">KEYC News Now This Morning</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/news/agriculture" class="color-white">Agriculture</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/news/crime" class="color-white">Crime</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/news/education" class="color-white">Education</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/health" class="color-white">Health</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/news/state/iowa" class="color-white">Iowa</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="/news/state/minnesota" class="color-white">Minnesota</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="/news/national" class="color-white">National</a> </div> </div> </div> </div> <div class="tray-section tray-section-3 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/weather" class="color-white">Weather</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/weather/closings" class="color-white">Closings</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://hb.511mn.org/#roadReports?timeFrame=TODAY&layers=allReports%2CroadReports%2CwinterDriving%2CweatherWarnings" class="color-white">Minnesota Road Conditions</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://hb.511ia.org/#allReports?timeFrame=TODAY&layers=allWinterReports%2Cincidents%2Cconstruction%2CweatherWarnings%2CotherStates%2CallReports" class="color-white">Iowa Road Conditions</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/weather/blog" class="color-white">Weather Blog</a> </div> </div> </div> </div> <div class="tray-section tray-section-4 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/sports" class="color-white">Sports</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/sports/high-school" class="color-white">High School</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/sports/ncaa" class="color-white">College</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/sports/extra" class="color-white">Sports Extra</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/sports/triple-play" class="color-white">Turning Two</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/sports/athlete" class="color-white">Prep Athlete of the Week</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/2019/05/24/prep-athlete-week-nomination/" class="color-white">Prep Athlete of the Week Nominations</a> </div> </div> </div> </div> <div class="tray-section tray-section-5 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/community" class="color-white">Community</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/programming/bandwagon" class="color-white">Bandwagon</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.keyc.com/community/best-of-the-class/" class="color-white">Best of the Class</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/community/calendar" class="color-white">Community Calendar</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/news/education/golden-apple" class="color-white">Golden Apple</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/2019/05/24/golden-apple-award-nominations/" class="color-white">Golden Apple Nominations</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/food/mrfood" class="color-white">Mr. Food</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="/pets/pick-of-the-litter" class="color-white">Pick of the Litter</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="/toys-for-tots/" class="color-white">Toys for Tots</a> </div> </div> </div> </div> <div class="tray-section tray-section-6 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/business" class="color-white">Business</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/business/hometown-connection" class="color-white">Hometown Connection</a> </div> </div> </div> </div> <div class="tray-section tray-section-7 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/programming/schedule" class="color-white">Programming Schedule</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.circleallaccess.com" class="color-white">Circle - Country Music & Lifestyle</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.fullcourtgreta.com/" class="color-white">Full Court Press with Greta Van Susteren</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://www.graydc.com/" class="color-white">Gray DC</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="https://www.investigatetv.com/" class="color-white">Investigate TV</a> </div> </div> </div> </div> <div class="tray-section tray-section-8 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/about-us" class="color-white">About Us</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/satellite/" class="color-white">Satellite Carriage Requests</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/keyc-channels/" class="color-white">Where to Find KEYC</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/neyc-channels/" class="color-white">Where to Find NEYC</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/about-us" class="color-white">Contact Us</a> </div> </div> </div> </div> </div> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0MEpCZXz0ktKr"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-keyc-breaking/" data-url="/pb/api/v2/render/feature" data-website="keyc" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="fZgFpz1Xz0ktKr"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/keyc-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="keyc"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fOcnHR1Xz0ktKr"> <div id="ad350-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad350" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad350",slotName:"keyc/web/politics",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"3IDTXRDJERCBLDYJJ4RXFV33I4"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="f0G8x4vXz0ktKr"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> <li class=""> <a class="tag unstyled-link call-to-action uppercase bold unstyled-link tag-first" href="https://www.keyc.com/politics"> Politics </a> </li> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">Minnesota lawmakers meet to pass aid for businesses, workers</h1> <h2 class="spaced spaced-xs spaced-top"></h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <img class="width-full " alt="Minnesota lawmakers meet to pass aid for businesses, workers" src="https://www.keyc.com/resizer/QO7qdabaXTi9b4Wymx5A5q_ZMbs=/1200x600/cloudfront-us-east-1.images.arcpublishing.com/raycom/JWCPJVZLWVAFNJLRKOVHZRRF4Y.jpeg"/> </div> <div class="container"> <figcaption class="caption-text spaced flex-container-row justify-space-between card card-article"> House Speaker Melissa Hortman, DFL-Brooklyn Park, speaks outside the House Chamber before the start of a special session, Wednesday, Oct. 14, 2020, in St. Paul, Minn. Democrats are looking for ways to finally pass a bonding bill this year. (Source: Glenn Stubbe/Star Tribune via AP) </figcaption> </div> </figure> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="c0qBKcXXz0ktKr"> <section id="article-sharebar" class="col col-no-gutter desktop-1 visible-lg spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share sharebar flex-container-column text-align-right"> <button class="social-icon spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=Minnesota+lawmakers+meet+to+pass+aid+for+businesses%2C+workers&amp;url=https%3A%2F%2Fwww.keyc.com%2F2020%2F12%2F14%2Fminnesota-lawmakers-meet-pass-aid-businesses-workers%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="fab fa-twitter social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> <button class="social-icon spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.keyc.com%2F2020%2F12%2F14%2Fminnesota-lawmakers-meet-pass-aid-businesses-workers%2F&amp;title=Minnesota+lawmakers+meet+to+pass+aid+for+businesses%2C+workers', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="fab fa-facebook-f social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> <a href="mailto:?subject=Minnesota%20lawmakers%20meet%20to%20pass%20aid%20for%20businesses%2C%20workers&amp;body=Read%20more%20on%20Minnesota%20lawmakers%20meet%20to%20pass%20aid%20for%20businesses%2C%20workers%20at%20https%3A%2F%2Fwww.keyc.com%2F2020%2F12%2F14%2Fminnesota-lawmakers-meet-pass-aid-businesses-workers%2F"> <button class="social-icon spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="far fa-envelope social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="f0z3yJ5Xz0ktKr"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> By <span class="font-bold color-black">STEVE KARNOWSKI</span> <span class="font-bold">|</span> <span class="timestamp"> December 14, 2020 at 3:37 PM CST - Updated December 14 at 3:43 PM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f0OiAz6Xz0ktKr"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>MINNEAPOLIS (AP) — Minnesota lawmakers convened Monday to pass a $216 million relief package aimed at businesses and workers who took the biggest hit from a four-week “pause” ordered by Gov. Tim Walz as increasing coronavirus cases threatened to overload hospitals.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Legislative leaders from both parties agreed last week on a key component of the package, a grant program for businesses such as bars and restaurants that the governor shut down last month for all but takeout and delivery service. They agreed Sunday night on the other major component of the bill, extending unemployment insurance for affected workers for 13 weeks starting Dec. 27. Both chambers were expected to easily pass the bill later Monday.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“This economic assistance package is a bridge until we receive more substantial assistance from the federal government,” Democratic House Majority Leader Ryan Winkler, of Golden Valley, said during a news conference. “But it won’t address all the needs of Minnesotans at this time. We know that.”</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>The package does not include some proposals that lawmakers floated earlier in the discussion stages, such as $500 one-time stimulus payments to low-income families sought by Democrats or any easing of liquor laws to let restaurants and bars sell larger containers of beer or cocktails to go. Negotiators said they focused on what all sides could accept so they could get the money out the door as soon as possible.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1230-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1230" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1230",slotName:"keyc/web/politics/3IDTXRDJERCBLDYJJ4RXFV33I4",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“With those two components, we’re taking care of the workers and we’re taking care of our businesses as fast as we possibly can,” Republican Rep. Dave Baker, of Willmar, who helped negotiate the package, told reporters Monday.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Walz plans to announce Wednesday&nbsp;<a href="https://www.keyc.com/2020/12/14/walz-plans-wednesday-announcement-whether-covid-restrictions-continue/" target="_blank">whether he’ll ease or extend any restrictions</a>&nbsp;past Friday’s expiration date. The “pause” also shut down high school and other organized youth sports, which is&nbsp;<a href="https://www.keyc.com/2020/12/10/parents-sue-walz-lift-pause-youth-sports-over-virus/" target="_blank">the subject of a lawsuit</a>.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Baker and other GOP lawmakers at a news conference faulted the Democratic governor for not giving businesses much advance word before he ordered the pause, and for twice postponing the announcement on whether he’ll relax or extend the restrictions. The announcement was first set for Friday, then moved to Monday, and&nbsp;<a href="https://www.keyc.com/2020/12/14/walz-plans-wednesday-announcement-whether-covid-restrictions-continue/" target="_blank">finally to Wednesday</a>&nbsp;because Walz wanted to see more data on whether a feared surge in cases due to Thanksgiving gatherings had materialized. Some businesses are threating to open this week in defiance of the governor’s order.</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad1633-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1633" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1633",slotName:"keyc/web/politics/3IDTXRDJERCBLDYJJ4RXFV33I4",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“We need to be able to start talking about trusting our business owners that want to help, want to be part of the solution. But when you keep leaving us in the dark it becomes incredibly frustrating, incredibly maddening,” Baker said. He said he doesn’t advocate violations, but understands why some business owners are impatient.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1712-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1712" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1712",slotName:"keyc/web/politics/3IDTXRDJERCBLDYJJ4RXFV33I4",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>The grant program is meant to quickly get money to the hardest-hit businesses, including fitness centers, breweries, wineries, bowling alleys and other venues. The Department of Revenue will send $90 million in automatic payments to hospitality businesses that have lost at least 30% of their sales. The grants will range from $10,000 to $45,000, depending on the number of employees.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>But $112 million of the package will be funneled through county governments to struggling businesses that don’t meet the criteria for automatic payments to ensure that they don’t fall through the cracks. A $14 million portion of the grants will be sent to movie theaters and convention centers through the Department of Employment and Economic Development.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Baker said they originally had hoped the money would start arriving in bank accounts by the end of the month, but that those grants might not arrive until early next month. He said they’re hoping the counties will send the grants by late January or early February.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>This will be Minnesota’s seventh special session of 2020. They became monthly affairs because Walz was required to call one each time he extended Minnesota’s peacetime state-of-emergency for another 30 days to renew the special executive authority he has used to manage the pandemic. Republican lawmakers have given up, for now, on trying to rescind those powers after being blocked repeatedly by the House Democratic majority. But they are expected to seek a greater say for the Legislature in the pandemic response during the 2021 regular session, which convenes Jan. 5.</p> </div> </div> <div data-type="text" class="card collection-item card-border-bottom card-border-bottom-thick card-border-bottom-dark"> <div class="card-content card-article"> <p><i>Copyright 2020 The Associated Press. All rights reserved.</i></p> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-connatix" id="fwaAKx1Xz0ktKr"> <div class="flex-grid ad-connatix spaced spaced-lg spaced-top spaced-bottom "> <div class="col desktop-12 tablet-12 mobile-12"> <div id="connatix-highlights-embed" class="connatix-container box-shadow-light"> <script id="a1c1c57f95064f50bba9396a0b142ced">cnxps.cmd.push(function(){cnxps({playerId:"e45c5d44-25b5-4226-8aec-29a25e6ac978"}).render("a1c1c57f95064f50bba9396a0b142ced")});</script> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f06efnJXz0ktKr"> <div id="outbrain-article-ad" class=""> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="https://www.keyc.com/2020/12/14/minnesota-lawmakers-meet-pass-aid-businesses-workers/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="https://www.keyc.com/2020/12/14/minnesota-lawmakers-meet-pass-aid-businesses-workers/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-ads-arcads tablet-6 mobile-12 desktop-12" id="fzMDJM1Xz0ktKr"> <div id="ad165-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad165" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad165",slotName:"keyc/web/politics",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"3IDTXRDJERCBLDYJJ4RXFV33I4"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-6 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="f47aum1Xz0ktKr"> <div class="invisible weather-gradient flex-grid color-white pb-weather day" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="day-clear" data-default-location-code="USMN0471" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="keyc" data-location-code="USMN0471" data-language="en" data-content-config-keys='Code,Language' data-content-config-values='USMN0471,en' data-custom-field-keys='spanish' data-custom-field-values=''/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="https://www.keyc.com/weather"> <img class="radar-image" src="//webpubcontent.raycommedia.com/keyc/Weather_Images/WebRadar.jpg" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="18" data-temp-c="-8"> 18</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/85_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in<br/>Mankato, MN</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="https://www.keyc.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast</button> </a> </div> </div> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-article-author-bio" id="frRRQ42Xz0ktKr"> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-mailchimp-signup" id="fxwHfN1Xz0ktKr"> <div class="card skin"> <div id="mc_embed_signup" class="card-media"> <form action="https://keyc.us19.list-manage.com/subscribe/post?u=400866fd432b2ff55667080e9&amp;id=50f9d31f24" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate> <div id="mc_embed_signup_scroll"> <label for="mce-EMAIL">Subscribe to KEYC News Now Updates</label> <input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required> <div style="position: absolute; left: -5000px;" aria-hidden="true"> <input type="text" name="b_400866fd432b2ff55667080e9_50f9d31f24" tabindex="-1" value=""> </div> <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div> </div> </form> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c0NRdx1Xz0ktKr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fhr3sb2Xz0ktKr"> <div class="flex-feature "> <h3 class="bold"><span class="rectangle"></span> RECENT CONTENT</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-153255" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2020/12/14/walz-plans-wednesday-announcement-whether-covid-restrictions-continue/"> <img class="width-full " alt="Walz plans Wednesday announcement on whether COVID restrictions continue" src="https://www.keyc.com/resizer/uNUlvuGUOuKV9rbGEoeB4hyrUvA=/1200x600/cloudfront-us-east-1.images.arcpublishing.com/raycom/HSE67NFATVGSLP6LOUHADXTBEQ.jfif"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/12/14/walz-plans-wednesday-announcement-whether-covid-restrictions-continue/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Walz plans Wednesday announcement on whether COVID restrictions continue</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">The restrictions on social gatherings, bars, restaurants, gyms and youth sports began at 11:59 p.m. on Nov. 20, and are currently scheduled to expire Dec. 18.</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Jake Rinehart</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f09JMK9Xz0ktKr"> <div id="ad1492-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1492" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1492",slotName:"keyc/web/politics",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"3IDTXRDJERCBLDYJJ4RXFV33I4"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c008fu9Xz0ktKr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fmrOMh1Xz0ktKr"> <div class="flex-feature "> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-134606" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/12/09/walz-convenes-special-session-urges-covid-relief-businesses/"> <img class="width-full " alt="Walz convenes special session, urges COVID relief for businesses" src="https://www.keyc.com/resizer/J_ck0ELWcZ8jQ9QKQxOj31j54hc=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/XAJBXB7ICNFDBCDMJSOCD7LF3E.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/12/09/walz-convenes-special-session-urges-covid-relief-businesses/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Walz convenes special session, urges COVID relief for businesses</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Jake Rinehart</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published December 9, 2020 at 11:20 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/12/07/walz-authorizes-disaster-assistance-sibley-renville-nicollet-counties/"> <img class="width-full " alt="Walz authorizes disaster assistance for Sibley, Renville, Nicollet counties" src="https://www.keyc.com/resizer/H57MGOxCiNdWEQCXh1NQosaPFOM=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/QDAMDKN2I5E4FFP3B2F6OTN42E.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/12/07/walz-authorizes-disaster-assistance-sibley-renville-nicollet-counties/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Walz authorizes disaster assistance for Sibley, Renville, Nicollet counties</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Jake Rinehart</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published December 8, 2020 at 7:35 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/12/08/sen-tina-smith-urges-mnsure-enrollment/"> <img class="width-full " alt="Sen. Tina Smith urges MNsure enrollment" src="https://www.keyc.com/resizer/2SuXIeMpSn7046_b78rH5s6LLm4=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/7Q4TEMTFLNAJVCVYRRXVBFDBQ4.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/12/08/sen-tina-smith-urges-mnsure-enrollment/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Sen. Tina Smith urges MNsure enrollment</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Meghan Grey</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published December 8, 2020 at 7:29 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/12/07/rochester-city-council-selects-alison-zelms-next-city-administrator/"> <img class="width-full " alt="Rochester City Council selects Alison Zelms as next city administrator" src="https://www.keyc.com/resizer/e0T8u3a0lkXgoLdxXUgKhdaEqwM=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/PJRADX53DJCVDLT43245CEY65M.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/12/07/rochester-city-council-selects-alison-zelms-next-city-administrator/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Rochester City Council selects Alison Zelms as next city administrator</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>KEYC Staff</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published December 7, 2020 at 10:36 PM </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="pb-container"> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f0XShVkXz0ktKr"> <div id="ad883-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad883" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad883",slotName:"keyc/web/politics",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"3IDTXRDJERCBLDYJJ4RXFV33I4"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="fU2oFF1Xz0ktKr"> <footer class="card card-dark padded padded-bottom padded-0"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.keyc.com"> <div class="logo logo-large logo-footer"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 1570 Lookout Drive<br/>North Mankato, MN 56003<br/>(507) 625-7905 </p> <a class="call-to-action uppercase color-white" href="/about-us">Contact Us <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div id="ccpa-link" class="call-to-action ccpa-dynamic-insertion-container uppercase color-white"></div> <div class="spaced spaced-top spaced-xl hidden-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="https://publicfiles.fcc.gov/tv-profile/keyc-tv" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@keyc.com" class="color-white">publicfile@keyc.com<br/>507-625-7905</a></li> <li><a href="https://webpubcontent.gray.tv/gdm/fcc/keyc-fcc_applications.pdf" class="color-white">FCC Applications</a></li> <li><a href="https://publicfiles.fcc.gov/tv-profile/keyc-tv/equal-employment-opportunity-records/additional-documents/eeo-public-file-reports/18b29fe3-d78a-5491-58a6-84d62d3a488a/" class="color-white">EEO Report</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">KEYC Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Services</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/keycnews12" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/keycnews12/" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://instagram.com/keycnews12" target="_blank" role="button" aria-label="Visit Instagram" rel="noopener noreferrer"> <i class="fab fa-instagram "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl visible-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="https://publicfiles.fcc.gov/tv-profile/keyc-tv" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@keyc.com" class="color-white">publicfile@keyc.com<br/>507-625-7905</a></li> <li><a href="https://webpubcontent.gray.tv/gdm/fcc/keyc-fcc_applications.pdf" class="color-white">FCC Applications</a></li> <li><a href="https://publicfiles.fcc.gov/tv-profile/keyc-tv/equal-employment-opportunity-records/additional-documents/eeo-public-file-reports/18b29fe3-d78a-5491-58a6-84d62d3a488a/" class="color-white">EEO Report</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">KEYC Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Services</a></li> </ul> </div> <div class="visible-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/keycnews12" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/keycnews12/" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://instagram.com/keycnews12" target="_blank" role="button" aria-label="Visit Instagram" rel="noopener noreferrer"> <i class="fab fa-instagram "></i> </a> </span> </div> </div> </div> </div> <div class="footer-copyright width-full bordered bordered-top-darken spaced spaced-top spaced-sm"> <div class="container"> <p class="font-sm color-white text-align-center spaced spaced-sm spaced-top spaced-bottom"> <span>A Gray Media Group, Inc. Station - &copy; 2002-2020 Gray Television, Inc.</span> </p> <div class="footer-corp-logo width-full spaced spaced-sm spaced-top spaced-bottom"></div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/rHJ9vP1Xz0ktKr/render.js?v=101'></script> <script>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</script> <script>window.banditoEnv={TIMEOUT:1500,PERF_API:"https://bandito-events.perso.aws.arc.pub/api/save-perf",TESTS_API:"https://bandito.perso.aws.arc.pub/api/variants",EVENTS_API:"https://bandito-events.perso.aws.arc.pub/api/save-event"};if(window["pageBuilder"]&&window["pageBuilder"]["initVariants"])window.pageBuilder.initVariants({IS_ADMIN:false,TIMEOUT:window.banditoEnv.TIMEOUT,PERF_API:window.banditoEnv.PERF_API,TESTS_API:window.banditoEnv.TESTS_API,EVENTS_API:window.banditoEnv.EVENTS_API});</script> <script async src="/pb/resources/dist/199071bbaf3b531cbc00/rm/rm-index199071bbaf3b531cbc00.js"></script>