<!DOCTYPE html><html lang="en"><head><script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=NodeList.prototype.forEach%2CArray.prototype.forEach%2CSymbol.hasInstance%2Ces6%2CIntl%2ClocalStorage%2CDate.prototype.toISOString%2CDate.now%2Cdefault%2CObject.entries%2CArray.prototype.entries"></script><title>NBC Sports Next&#x27;s SportsEngine Forms Partnership with U.S. Center for SafeSport</title><meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"/><meta http-equiv="X-UA-Compatible" content="IE=edge"/><meta charSet="UTF-8"/><meta name="distribution" content="global"/><meta name="rating" content="general"/><meta name="copyright" content="Copyright (c) 2021 "/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta name="apple-itunes-app" content="app-id=550428346"/><meta name="google-play-app" content="app-id=com.mobdub.channel.KEYC"/><meta name="burst" content="keyc"/><meta property="og:url" content="https://www.keyc.com/prnewswire/2021/11/09/nbc-sports-nexts-sportsengine-forms-partnership-with-us-center-safesport/"/><meta name="robots" content="noindex"/><meta name="googlebot" content="noindex"/><meta name="googlebot-news" content="noindex"/><meta itemProp="description" name="description" content="SportsEngine to offer SafeSport content and training resources within its platform, furthering safety standards in youth sports"/><meta property="og:description" content="SportsEngine to offer SafeSport content and training resources within its platform, furthering safety standards in youth sports"/><meta name="twitter:description" content="SportsEngine to offer SafeSport content and training resources within its platform, furthering safety standards in youth sports"/><meta property="fb:admins" content="644426401"/><meta property="fb:app_id" content="103460183161125"/><meta property="fb:pages" content="103460183161125"/><meta property="article:publisher" content="https://www.facebook.com/keycnewsnow/"/><meta name="keywords" content=""/><meta name="news_keywords" content=""/><meta itemProp="image" property="og:image" content="https://gray-keyc-prod.cdn.arcpublishing.com/resizer/9UPpgFayuml8l454Qosga3Kq3NI=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/ZKQOJVA67G5OQWRE5AUGZGCGME.jpg"/><meta name="twitter:image" content="https://gray-keyc-prod.cdn.arcpublishing.com/resizer/9UPpgFayuml8l454Qosga3Kq3NI=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/ZKQOJVA67G5OQWRE5AUGZGCGME.jpg"/><meta property="og:site_name" content="https://www.keyc.com"/><meta property="og:title" content="NBC Sports Next&#x27;s SportsEngine Forms Partnership with U.S. Center for SafeSport"/><meta name="twitter:title" content="NBC Sports Next&#x27;s SportsEngine Forms Partnership with U.S. Center for SafeSport"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@keycnewsnow"/><meta name="twitter:creator" content="@keycnewsnow"/><script type="application/ld+json" data-schema="NewsMediaOrganization">{
  "name": "KEYC",
  "url": "https://www.keyc.com",
  "logo": {
    "@type": "ImageObject",
    "url": "https://www.keyc.com/pf/resources/images/logo-off-site/keyc.png?d=202"
  },
  "@type": "NewsMediaOrganization",
  "sameAs": [
    "https://www.facebook.com/keycnewsnow/",
    "https://www.instagram.com/keycnewsnow/",
    "https://www.twitter.com/keycnewsnow/"
  ],
  "@context": "http://schema.org"
}</script><script type="application/ld+json" data-schema="NewsArticle">{
  "name": "NBC Sports Next's SportsEngine Forms Partnership with U.S. Center for SafeSport",
  "url": "https://www.keyc.com/prnewswire/2021/11/09/nbc-sports-nexts-sportsengine-forms-partnership-with-us-center-safesport/",
  "image": "https://gray-keyc-prod.cdn.arcpublishing.com/resizer/9UPpgFayuml8l454Qosga3Kq3NI=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/ZKQOJVA67G5OQWRE5AUGZGCGME.jpg",
  "@type": "NewsArticle",
  "@context": "http://schema.org",
  "description": "SportsEngine to offer SafeSport content and training resources within its platform, furthering safety standards in youth sports",
  "keywords": [],
  "headline": "NBC Sports Next's SportsEngine Forms Partnership with U.S. Center for SafeSport",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.keyc.com/prnewswire/2021/11/09/nbc-sports-nexts-sportsengine-forms-partnership-with-us-center-safesport/"
  },
  "author": {
    "@type": "Organization",
    "name": "KEYC"
  },
  "publisher": {
    "name": "KEYC",
    "url": "https://www.keyc.com",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.keyc.com/pf/resources/images/logo-off-site/keyc.png?d=202"
    },
    "@type": "NewsMediaOrganization"
  },
  "datePublished": "2021-11-09T15:00:00Z",
  "datemodified": "2021-11-09T15:00:00Z"
}</script><script type="application/javascript" id="polyfill-script">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=202" defer=""><\/script>')}</script><script id="fusion-engine-react-script" type="application/javascript" src="/pf/dist/engine/react.js?d=202" defer=""></script><script id="fusion-engine-combinations-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=202" defer=""></script><link id="fusion-template-styles" rel="stylesheet" type="text/css"/><link rel="stylesheet" href="https://gray-keyc-prod.cdn.arcpublishing.com/pf/resources/dist/__global/css/main.css?d=202"/><link rel="stylesheet" href="https://gray-keyc-prod.cdn.arcpublishing.com/pf/resources/dist/keyc/css/main.css?d=202"/><link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.15.4/css/all.min.css?d=202" rel="stylesheet"/><link rel="icon" type="image/x-icon" href="/pf/resources/images/favicons/keyc/favicon.ico?d=202"/><script type="text/javascript" src="https://gray-keyc-prod.cdn.arcpublishing.com/pf/resources/js/analytics/gtm.js?d=202"></script><script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://reconditerespect.com/v2kgz_gZwMtdQ-MXx1ZTGRJIrgvEBn96JTtPVrclNhoOgSQnse5hAa8Gt",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");;;;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://reconditerespect.com/v2ufmF9jGLeMMbTgj9HfFELGE6T_RuT6TgqwYJpgr0fOi8ijcm61JirTq9gyrrwIFs6FpryH8aA",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script><script type="text/javascript" src="https://gray-keyc-prod.cdn.arcpublishing.com/pf/resources/js/ads/arcads.js?d=202"></script><script type="text/javascript">
    var RCdataLayer = [
      {
        adTarget: "/wires/press-releases",
        authors: [ ],
        canonicalUrl: "https://www.keyc.com/prnewswire/2021/11/09/nbc-sports-nexts-sportsengine-forms-partnership-with-us-center-safesport/",
        contentId: "KEKTKOFND5CIHABIRZQVF6FE5A",
        contentKewords: [ ],
        contentName: "NBC Sports Next\'s SportsEngine Forms Partnership with U.S. Center for SafeSport",
        contentOwner: "gray",
        contentTags: [ ],
        contentType: "story",
        datePublished: "11/09/2021",
        distributorCategory: "wires",
        distributorMode: "reference_denormalized",
        distributorName: "PRNewswire",
        distributorReferenceId: "cc164599-a609-4ade-ad67-ab71070d59c1",
        distributorSubCategory: "prnewswire",
        hasVideo: false,
        metaDescription: "SportsEngine to offer SafeSport content and training resources within its platform, furthering safety standards in youth sports",
        outputType: "default",
        platformName: "PageBuilder Fusion - Arc Publishing",
        primarySection: {
          _id:  "/wires/press-releases",
          name:  "Press Releases",
          path:  "/wires/press-releases"
        },
        publishedDay: "09",
        publishedMonth: "11",
        publishedYear: "2021",
        stationName: "keyc",
        subtype: null,
        timezoneOffset: gdmGoogleTagManager.getTimezoneOffset(),
        userId: null,
        userTimezoneTimestamp: new Date(),
        userTimezone: Intl.DateTimeFormat().resolvedOptions().timeZone,
        userAgent: navigator.userAgent
      }
    ];
  </script><script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','RCdataLayer','GTM-M5QQ3JP');</script>
<script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-6422ec37-1258-4e33-8aec-75eec9dba379","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"false","rua.texp":"norulematch"}]);</script>
                              <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="N3LNQ-GWNXD-VDNAR-5G8S7-Y2EZ7",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"N3LNQ-GWNXD-VDNAR-5G8S7-Y2EZ7",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubaxezywsymktqvq-f-c141beb5f-clientnsv4-s.akamaihd.net",i="false"=="true"?2:1,_={"ak.v":"32","ak.cp":"1137287","ak.ai":parseInt("676960",10),"ak.ol":"0","ak.cr":14,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"e0a4b91","ak.r":36658,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":59826,"ak.gh":"23.38.113.101","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1636473899","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==e4dfobJB6YxZL8fTbuLQ3ZtMGTDOmLdepcLFlQJb/FzsuPqgPui7CKGR/clD/EOXz/b/WyMtnUrUrANwUR2kDIk/V2N5OEng1hY4Gqx6wkEUDp6H8gTqloydv4Fwia62f8WAWXlaeJu/dld2gVNbmKmY1j1+sgwvbT/CHEIE1i2UE9yKAsfqTWePTALMqgGvPCvHP71StrqeNFQPfydDlJhB3it4mM/P5KmSkcLTwm8ENt0jw+wIN9XzDSovlU2BExrZNEfB+mWNfHLvGPNSoAq7etuITFlgHYqL1F5HOYu1shz9E3DatVyYn7C1Hw6jeUsbKKto/v1QsL0AEfshV+lpP+64jovuJiwNaVSlo6snnTXOgIhWmwpPVzDFled1B2XEbJv+lBbzOuzjH/kI3FvPWjjwNKn2eqsQwnpG2CY=","ak.pv":"7","ak.dpoabenc":"","ak.tf":i};if(""!==t)_["ak.ruds"]=t;var o={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))_["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(_)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t","ak.tf"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:_,akDNSPreFetchDomain:n,init:function(){if(!o.i){var a=BOOMR.subscribe;a("before_beacon",o.av,null,null),a("onbeacon",o.rv,null,null),o.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fusion-app" class="fusion-app"><div id="article-right-rail-layout" class="includes-right-rail"><a class="skip-link sr-only sr-only-focusable px-3 text-body" href="#main">Skip to content</a><header id="main" class="masthead | w-100"><div class="sales-navigation | d-none w-100 bg-primary-branding d-lg-flex"><div class="container-xl"><div class="sales-nav-links | d-flex justify-content-start py-1"><div class="sales-nav-link |"><a class="text-nowrap text-reset text-decoration-none" href="/community/user-content">Your Photos</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/weather/closings">Closings</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/community/calendar">Community Calendar</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/programming/schedule">What&#x27;s On CBS, FOX, NBC, &amp; CW</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/contests">Our Contests</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/about-us">About Us</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/2019/11/15/programming-start-soon-nbc-cw/">About KEYC NBC</a></div></div></div></div><div class="masthead | bg-primary-branding py-2" style="background-image:url(&#x27;/pf/resources/images/mastheads/backgrounds/keyc.jpg?d=202&#x27;)"><div class="container-xl"><div class="d-flex justify-content-between w-100"><div class="logo flex-fill position-relative"><a class="logo-link" aria-label="Return to the Homepage" href="/"><div class="logo-inner position-absolute" style="background-image:url(&#x27;/pf/resources/images/mastheads/logos/keyc.svg?d=202&#x27;)"></div></a></div></div></div></div></header><nav class="navigation | w-100"><div class="navigation | navigation-sticky-wrapper" style="min-height:undefinedpx"><div class="navbar | navbar-expand bg-primary-branding"><div class="container-xl position-relative"><a class="navbar-brand mr-1 d-none" aria-label="Return to the Homepage" href="/"><div class="brand-logo" style="background-image:url(&quot;/pf/resources/images/logo-icons/keyc.svg?d=202&quot;)"></div></a><button aria-label="Expand Side Navigation Panel" class="side-drawer-toggle btn text-white" type="button"><span class="fas fa-bars"></span></button><ul class="navbar-links | navbar-nav mr-auto font-weight-bold"><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/news">News</a></li><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="https://www.graytvlocal.com/market/mankato-mn" rel="noopener noreferrer" target="_blank">Business Guide</a></li><li class="navbar-link | navbar-item d-none d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/livestream">Watch Live</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/weather">Weather</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/sports">Sports</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/community">Community</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/health/coronavirus">Coronavirus</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="https://grow.withgray.tv/keyc/" rel="noopener noreferrer" target="_blank">Advertise</a></li></ul><form class="search-box bg-primary-branding d-flex flex-row rounded position-absolute zindex-high w-auto p-1" action="/search/" method="GET" role="search"><input type="text" class="form-control form-control-sm bg-primary-branding m-0 p-0 border-0" aria-label="Enter search term" id="expandable-search" name="searchTerm" placeholder="Search..."/><button class="btn border-0 text-white" aria-label="Toggle search bar" type="button"><i class="d-block fas fa-search"></i></button><button class="btn btn-sm text-white border border-secondary sr-only" aria-label="Toggle search bar" type="submit">Search</button></form></div></div></div><div class="side-drawer-screen | fixed-top h-100 w-100 zindex-high"></div><div class="side-drawer | bg-primary-branding shadow-lg fixed-top h-100 w-100 overflow-y overflow-hide-scrollbar"><div class="side-drawer-container | d-none flex-column align-items-end h-100"><div class="side-drawer-cancel | w-100 p-2"><div class="d-flex flex-column align-items-end"><button aria-label="Close" class="btn btn-sm text-white"><i class="fas fa-times"></i></button></div></div><ul class="sections-list | list-unstyled w-100 pt-5 pb-4"><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/homepage">Home</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Home navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/user-content">Your Photos</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/livestream">Watch Live</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/2019/05/24/send-us-news-tip/">Send Us A News Tip</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news">News</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the News navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/morning">KEYC News Now This Morning</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/agriculture">Agriculture</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/crime">Crime</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/education">Education</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health">Health</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/local">Local</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/state/iowa">Iowa</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/state/minnesota">Minnesota</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/national">National</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/weather">Weather</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Weather navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/closings">Closings</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://hb.511mn.org/#roadReports?timeFrame=TODAY&amp;layers=allReports%2CroadReports%2CwinterDriving%2CweatherWarnings" rel="noopener noreferrer" target="_blank">Minnesota Road Conditions</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://hb.511ia.org/#allReports?timeFrame=TODAY&amp;layers=allWinterReports%2Cincidents%2Cconstruction%2CweatherWarnings%2CotherStates%2CallReports" rel="noopener noreferrer" target="_blank">Iowa Road Conditions</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/maproom">Map Room</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/blog">Weather Blog</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/sports">Sports</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Sports navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/high-school">High School</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/ncaa">College</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/extra">Sports Extra</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/maverick-hockey-quick-hits">Maverick Hockey Quick Hits</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/athlete">Prep Athlete of the Week</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/2019/05/24/prep-athlete-week-nomination/">Prep Athlete of the Week Nomination</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community">Community</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Community navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/programming/bandwagon">Bandwagon</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/calendar">Community Calendar</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/giveback">Good Morning Giveback</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/education/golden-apple">Golden Apple</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/2019/05/24/golden-apple-award-nominations/">Golden Apple Nominations</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/pets/pick-of-the-litter">Pick of the Litter</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/food/mrfood">Mr. Food</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/business">Business</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Business navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/business/hometown-connection">Hometown Connection</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/programming/schedule">Programming Schedule</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/about-us">About Us</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the About Us navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/about-us/contact-us">Contact Us</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/about-us/meet-the-team">Meet The Team</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/keyc-tv-satellite-carriage-request">Satellite Carriage Request</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/user-content">Submit Photos and Video</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.vuit.com/live/17539/keyc" rel="noopener noreferrer" target="_blank">Watch Previous Newscasts</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.fullcourtgreta.com/" rel="noopener noreferrer" target="_blank">Full Court Press with Greta Van Susteren</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.graydc.com" rel="noopener noreferrer" target="_blank">Gray DC</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="http://www.circleallaccess.com/" rel="noopener noreferrer" target="_blank">Circle - Country Music &amp; Lifestyle</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.investigatetv.com/" rel="noopener noreferrer" target="_blank">Investigate TV</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/powernation">PowerNation</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/wires/press-releases">Press Releases</a></div></li></ul><div class="social-bar | d-flex flex-row justify-content-center w-100 mt-auto p-3" style="bottom:0"><a aria-label="Visit KEYC on FACEBOOK" class="p-2" href="https://www.facebook.com/keycnewsnow" rel="noopener noreferrer" target="_blank"><i class="fab fa-facebook-f fa-2x"></i></a><a aria-label="Visit KEYC on INSTAGRAM" class="p-2" href="https://www.instagram.com/keycnewsnow" rel="noopener noreferrer" target="_blank"><i class="fab fa-instagram fa-2x"></i></a><a aria-label="Visit KEYC on TWITTER" class="p-2" href="https://www.twitter.com/keycnewsnow" rel="noopener noreferrer" target="_blank"><i class="fab fa-twitter fa-2x"></i></a></div></div></div><div class="breaking-news-bar |"></div><div id="fusion-static-enter:f0fgruVYP9iIdU" style="display:none" data-fusion-component="f0fgruVYP9iIdU"></div><div id="htmlBox-f0fgruVYP9iIdU" class="html-box | w-100 p-3 mb-3"><div class="html-box-container" id="htmlBox-f0fgruVYP9iIdU-container"><div class="mb-3" /></div></div><div id="fusion-static-exit:f0fgruVYP9iIdU" style="display:none" data-fusion-component="f0fgruVYP9iIdU"></div></nav><section class="leaderboard | w-100"></section><div class="container-xl"><div class="row"><section class="top-wrapped | col-12"><div class="article-header article row mb-3"><div class="headlines |"><h1 class="headline | font-weight-bold col"><span>NBC Sports Next's SportsEngine Forms Partnership with U.S. Center for SafeSport</span></h1><h5 class="subheadline | font-weight-light col"><span>SportsEngine to offer SafeSport content and training resources within its platform, furthering safety standards in youth sports</span></h5></div><div class="date-time | col-12"><span class="date-time published-date-time font-italic d-inline-block">Published: <!-- -->Nov. 9, 2021 at 9:00 AM CST</span><span class="px-2 d-inline">|</span><span class="date-time updated-date-time font-italic d-inline-block">Updated: <!-- -->1 hour ago</span></div></div><div class="article-body | article w-100"><p class="text | article-text"><span class="xn-location">MINNEAPOLIS</span>, <span class="xn-chron">Nov. 9, 2021</span> /PRNewswire/ --<b> </b>NBC Sports Next, the sports technology division of NBC Sports and home to youth sports software platform, <u><a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3352773-1&amp;h=2699898229&amp;u=http%3A%2F%2Fwww.sportsengine.com%2F&amp;a=SportsEngine" rel="nofollow" target="_blank">SportsEngine</a></u>, announced today it has formed a partnership with the <u><a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3352773-1&amp;h=273900122&amp;u=https%3A%2F%2Fuscenterforsafesport.org%2F&amp;a=U.S.+Center+for+SafeSport" rel="nofollow" target="_blank">U.S. Center for SafeSport</a></u> (Center). The new agreement establishes a long-term partnership between the two entities and names SportsEngine a Preferred Membership Platform Provider of the U.S. Center for SafeSport.</p><figure class="image | figure article-image w-100 primary"><div class="img-wrapper figure-img"><img class="img-fluid mx-auto d-block" alt="SportsEngine Inc. Logo (PRNewsfoto/SportsEngine Inc.)" height="300" src="https://gray-keyc-prod.cdn.arcpublishing.com/resizer/g4DUnI-3jmOicZOODjEWAyPW5dU=/980x0/smart/filters:quality(85)/mma.prnewswire.com/media/947008/SportsEngine_Logo.jpg" width="980"/></div><figcaption class="figure-caption">SportsEngine Inc. Logo (PRNewsfoto/SportsEngine Inc.)</figcaption></figure><p class="text | article-text">The mission of the U.S. Center for SafeSport is making athlete well-being the centerpiece of our nation's sports culture through abuse prevention, education, and accountability. An independent nonprofit, the Center opened in <span class="xn-chron">March 2017</span> and provides sports organizations at all levels with methods, policies, and programs to help prevent abuse. It serves as a professional and confidential place for more than 11 million athletes, coaches, and other participants in the U.S. Olympic and Paralympic Movement to report sexual, emotional, and physical abuse and misconduct.</p><p class="text | article-text">The U.S. Center for SafeSport's Core Trained course is required for millions of adult participants in the U.S. Olympic and Paralympic Movement, whose 55 national governing bodies encompass over 11 million members. Through this partnership, the Center—the nation's federally designated national safe sport organization—offers all SportsEngine users the ability to complete Core training and many more abuse awareness and prevention online courses within the SportsEngine HQ platform, which can seamlessly track eligibility and credentials for athletes, coaches, and other sport participants. SportsEngine will also publish Center athlete safety guidance and resources to its millions of parents, athletes, coaches and league administrator users.</p><p class="text | article-text">"Partnering with SportsEngine will greatly expand access to SafeSport abuse awareness and prevention trainings and resources, enabling athletes and allies across America to accelerate positive culture change at every level of sport," said Ju'Riese Colón, CEO of the U.S. Center for SafeSport. "SportsEngine's technology and vast reach in youth sports will help us educate and train more athletes, coaches, parents, and administrators to recognize, prevent, and respond to abuse in sport settings."</p><p class="text | article-text">"We are honored to partner with U.S. Center for SafeSport to serve as a resource as they continue their mission to advocate for safety in youth sports," stated <span class="xn-person">Brett MacKinnon</span>, SVP and General Manager, Youth and <span class="xn-person">Rec Sports</span>, NBC Sports Next. "Helping to provide safe, positive youth sports experiences is a moral imperative and remains at the core of what we do at SportsEngine. We are proud to support the U.S. Center for SafeSport as it works to fulfill its vision of changing the culture of sports, set higher standards for youth and amateur sport organizations and establish training, policies and best practices for protecting athletes."</p><p class="text | article-text">Helping to ensure athlete safety on and off the field is one of the highest priorities for SportsEngine and is aligned with its focus on increasing access to sports and simplifying the lives of parents, coaches and administrators with its software solutions. More than a million teams, leagues and clubs use SportsEngine software to run their tournaments, leagues, online registration, websites, and mobile apps. Additionally, National Center for Safety Initiatives (NCSI), a wholly owned subsidiary of SportsEngine, is a youth safety advocacy group and leading background screening provider. Through these applications, sports teams, clubs, leagues, and national governing bodies have access to a single source for league management, staff eligibility and safety resources to ensure coaches and volunteers are properly screened, trained and eligible to interact with youth athletes.</p><p class="text | article-text"><b>About NBC Sports Next<br/></b>NBC Sports Next is a subdivision of NBC Sports and home to all NBCUniversal digital applications in sports and technology within its three groups: Youth & Recreational Sports, Golf, and Betting & Gaming. NBC Sports Next, known for its sports technology product innovation, equips more than 30MM players, coaches, athletes, sports administrators and fans in 40 countries with more than 25 sports solution products, including <u><a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3352773-1&amp;h=2699898229&amp;u=http%3A%2F%2Fwww.sportsengine.com%2F&amp;a=SportsEngine" rel="nofollow" target="_blank">SportsEngine</a></u>, the leading youth sports club, league and team management platform; <u><a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3352773-1&amp;h=3203303578&amp;u=https%3A%2F%2Fwww.teamunify.com%2Fswim-team-management-software%2F&amp;a=TeamUnify" rel="nofollow" target="_blank">TeamUnify</a></u>, swim team management services; <u><a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3352773-1&amp;h=2792969316&amp;u=https%3A%2F%2Fwww.gomotionapp.com%2Fsolutions&amp;a=GoMotion" rel="nofollow" target="_blank">GoMotion</a></u>, sports and fitness business software solutions; <u><a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3352773-1&amp;h=2102707585&amp;u=http%3A%2F%2Fwww.golfnow.com%2F&amp;a=GolfNow" rel="nofollow" target="_blank">GolfNow</a></u>, the leading online tee time marketplace and provider of golf course operations technology and services; <u><a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3352773-1&amp;h=2105306738&amp;u=https%3A%2F%2Fwww.golfpass.com%2F&amp;a=GolfPass" rel="nofollow" target="_blank">GolfPass</a></u><b> </b>the ultimate golf membership that connects golfers to exclusive content, tee time credits, coaching, tips and other benefits; and <u><a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3352773-1&amp;h=2049136966&amp;u=https%3A%2F%2Fwww.nbcsportsedge.com%2F&amp;a=NBC+Sports+Edge" rel="nofollow" target="_blank">NBC Sports Edge</a></u>, (formerly Rotoworld) a leading platform for fantasy sports information and betting-focused tools. NBC Sports Next is fueled by its mission to innovate, create larger-than-life events and connect with sports fans through technology to provide the ultimate in immersive experiences.</p><p class="text | article-text"><b>About US Center for SafeSport<br/></b>Headquartered in <span class="xn-location">Denver, Colorado</span>, the U.S. Center for SafeSport is an independent, nonprofit 501(c)(3) responsible for responding to and preventing emotional, physical, and sexual misconduct and abuse in the U. S. Olympic and Paralympic Movement. The Center's mission is to make athlete well-being the centerpiece of our nation's sports culture through abuse prevention, education, and accountability.</p><p class="text | article-text">The Center also serves as an educational resource for sports organizations at all levels, from grassroots amateur sports organizations to professional leagues. For more information, please visit <u><a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3352773-1&amp;h=2541539414&amp;u=https%3A%2F%2Fuscenterforsafesport.org%2F&amp;a=https%3A%2F%2Fuscenterforsafesport.org%2F" rel="nofollow" target="_blank">https://uscenterforsafesport.org/</a></u>.</p><p class="text | article-text">View original content to download multimedia:</p><div class="interstitial-link | border-0 mb-3"><div class="p-2"><div class="align-self-center"><h6 class="mb-0 font-weight-bold"><a class="" href="https://www.prnewswire.com/news-releases/nbc-sports-nexts-sportsengine-forms-partnership-with-us-center-for-safesport-301419995.html">https://www.prnewswire.com/news-releases/nbc-sports-nexts-sportsengine-forms-partnership-with-us-center-for-safesport-301419995.html</a></h6></div></div></div><p class="text | article-text">SOURCE  NBC Sports Next</p><figure class="image | figure article-image w-100 primary"><div class="img-wrapper figure-img mb-0"><img class="img-fluid mx-auto d-block" height="300" src="https://gray-keyc-prod.cdn.arcpublishing.com/resizer/8VrPyXUmCCCORzZWlhN9n9FQY-I=/980x0/smart/filters:quality(85)/rt.prnewswire.com/rt.gif?NewsItemId=AQ69568&amp;Transmission_Id=202111091000PR_NEWS_USPR_____AQ69568&amp;DateId=20211109" width="980"/></div></figure></div><div class="article-body | article w-100"><p class="text | article-text"><i>The above press release was provided courtesy of PRNewswire. The views, opinions and statements in the press release are not endorsed by Gray Media Group nor do they necessarily state or reflect those of Gray Media Group, Inc.</i></p></div></section><div class="col-12 d-flex flex-column flex-lg-row w-100"><div class="article-content-container | flex-lg-fill mr-lg-3"><section class="header | w-100"></section><section class="body | w-100"></section><section class="recommendations | w-100"></section></div><section class="right-rail | rail ml-lg-3 d-flex flex-column flex-lg-fill"></section></div><section class="bottom-wrapped | col-12"></section></div></div><footer class="footer | w-100"><div id="fusion-static-enter:footer-keyc" style="display:none" data-fusion-component="footer-keyc"></div><div class="footer | card bg-primary-branding mt-3 d-flex rounded-0 text-center text-sm-left zindex-highest"><div class="card-body"><div class="container"><div class="row"><div class="col"><div class="footer-links | row justify-content-start my-3"><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/homepage">Home</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news">News</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/weather">Weather</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/sports">Sports</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/community">Community</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/about-us">About Us</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/community/user-content">Submit Photos and Videos</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/livestream">Livestream</a></div></div></div><div class="col-12 col-sm-5 col-md-3 col-xl-2"><div class="footer-contacts | row justify-content-start my-3 small"><div class="col"><ul class="list-unstyled mb-0"><li class="footer-contact | font-weight-bold">KEYC</li><li class="footer-contact | footer-address">1570 Lookout Drive</li><li class="footer-contact | footer-city-state">North Mankato, MN 56003</li><li class="footer-contact | footer-phone">(507) 625-7905</li></ul></div></div></div></div></div></div><div class="card-footer small pt-0"><div class="footer-links | d-flex flex-wrap justify-content-center text-center"><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/tv-profile/keyc-tv" rel="noopener noreferrer" target="_blank">FCC Public Inspection File</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/tv-profile/keyc-tv/equal-employment-opportunity-records/" rel="noopener noreferrer" target="_blank">EEO Report</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="mailto:publicfile@keyc.com" rel="noopener noreferrer" target="_blank">507-625-7905 - publicfile@keyc.com</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/tv-profile/keyc-tv/applications-and-related-materials/" rel="noopener noreferrer" target="_blank">FCC Applications</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/terms-of-service" rel="noopener noreferrer" target="_blank">Terms of Service</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/privacy-policy" rel="noopener noreferrer" target="_blank">Privacy Policy</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/advertising" rel="noopener noreferrer" target="_blank">Advertising</a></div><div id="ccpa-link" class="ccpa-dynamic-insertion-container d-flex align-self-center"></div></div></div><div class="footer-copyright | card-footer"><div class="font-weight-light small mx-auto text-center">A Gray Media Group, Inc. Station - <!-- -->© <!-- --> <!-- -->2002-2021 Gray Television, Inc.</div><div class="footer-corp-logo | w-100 mx-auto mt-2 mb-0"></div></div></div><div id="fusion-static-exit:footer-keyc" style="display:none" data-fusion-component="footer-keyc"></div></footer></div></div><script id="fusion-metadata" type="application/javascript">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</script></body></html>